Incident detected
Incident Report for RaiseNow
Resolved
This incident has been resolved.
Posted May 02, 2024 - 10:23 CEST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 02, 2024 - 09:36 CEST
Identified
We are aware of an issue affecting our services and currently working on identifying its root cause.
You can expect an update on the incident in the next hour.
Posted May 02, 2024 - 09:04 CEST
This incident affected: Donation Forms.