TWINT services are partially unavailable
Incident Report for RaiseNow
Resolved
TWINT could resolve the issue.
Posted Sep 14, 2023 - 11:20 CEST
Monitoring
TWINT is currently experiencing an issue with its services. We will provide an update as soon as we have further information on the issue.
Posted Sep 14, 2023 - 10:49 CEST
This incident affected: Payment Providers (TWINT).