Incident detected
Incident Report for RaiseNow
Resolved
This incident has been resolved. We apologize for the inconvenience and thank you for your understanding. We are continuously working on improvements to make our services better.
Posted Nov 12, 2022 - 07:37 CET
Investigating
We are aware of an issue affecting our services and currently working on identifying its root cause.
You can expect an update on the incident in the next hour.
Posted Nov 12, 2022 - 07:31 CET