The 3rd party service provider has fixed the issue and is currently monitoring its systems.
Posted Feb 05, 2025 - 08:34 CET
Investigating
A 3rd party service provider is currently experiencing an issue with its services. Due to this, the card payment selection in solutions at donate.raisenow.io, pay.raisenow.io, or tamaro.raisenow.com may not load or timeout. We will provide an update as soon as we have further information on the issue.
Posted Feb 05, 2025 - 04:39 CET
This incident affected: Payment Services and Payment Providers (Stripe).